Welcome to Certabo forum

Both posts in italian and in english are accepted on the forum to help everybody to provide contribution irrespective to geographical location. Object of the forum is to provide technical information on various items and help developer and users to personalise software for Certabo chessboards. User explicitly accepts the conditions of use of this forum here reported.

A brief introduction of user is always appreciated in section Welcome to….

Benvenuti nel forum di Certabo

Sul forum possono essere postati articoli sia in lingua italiana che inglese per permettere a tutti di dare il proprio contributo da diversi luoghi geografici. Il forum ha come scopo fornire informazioni tecniche in generale e aiutare gli sviluppatori ed utenti a personalizzare software per le scacchiere Certabo. L’utente accetta esplicitamente le condizioni del presente forum consultabili qui.

Un breve saluto del nuovo utente è sempre gradito nella sezione Benvenuti a….

Please or Register to create posts and topics.

Drivers for Arena, LucasChess and Shredder

A few years ago I wrote a UCI "engine" to control my Novag UCB board and then converted it to a DLL library that allowed it to interface directly with Arena and LucasChess. I have now updated it to work with the new LucasChessR and have also added support for the Shredder GUI.

I saw Lars Nowak had a UCI engine for Certabo boards:

http://www.solanosoft.com/index.php?page=certabo-uci

I thought this meant I could easily convert my DLL for Certabo, like I did with the Novag, but it turned out to be a bit more complex than I'd expected! With his help, and lots of assistance from Pietro, I have now completed version 1 of my file. So now Certabo boards can interface directly with Arena, LucasChess, LucasChessR and Shredder.

They already come preinstalled in LucasChessR (from R0.35a) but need to be loaded manually for the other GUIs. For those GUIs my drivers all use the same file name, so if you also have a UCB or Millennium board then you will need to be careful about which version of my driver is loaded! Instructions are included in the downloads available here:

https://goneill.co.nz/chess

There is no support for Chess960 or setting up positions using the board yet, but I hope to add those later.

I looked at Aquarium but it doesn't appear to use a DLL file so I can't implement this driver there. I also looked at Fritz, and although I can get it to load and run my driver it seems to be doing some validation I'm unaware of. Unless I can work out what, I won't be able to implement my driver there either.

These are still first release so there might be some bugs but between Lars, Pietro and myself I think we've caught most of them!

Hello Graham

Thank you very much for your effort and support!! It was pleasure for us to help and vey happy the family of supporters is growing every day.

Please guys post here any experience suggestion.

All the best and stay always safe!

Pietro

I tried to install the dll with Arena but unfortunately without success.
In the logfile it says:

9:44:51.296 [ Main ] --- ---: (Config changed)
9:44:51.312 [Thread] --- ---: (All connections failed)
9:45:43.890 [ Main ] --- ---: (OK rejected)
9:45:54.015 [Thread] --- ---: (All connections failed)
9:46:02.421 [ Main ] GUI ---: HideDialog
9:46:02.421 [Thread] --- ---: (CER thread finishing)

The only thing which is different to the PDF´s description is that option show TSLDKB pieces an not RNBQKP
I also tried Shredder and Lucas chess, but registration didn´t work in any app.

 

The UCI drivers form Lars worked but there is no takeback option that´s why I would really love to make the new dll work.....

Hi Julkal,

The TSLDKB should be changed but that won't affect the connection itself.

I normally find it won't connect to the board if another program was using the COM port and didn't release it properly, or if Windows allowed the port to shut down to save power. The easiest solution is normally to unplug the USB cable at the computer and then reconnect it. Leave a few seconds for the LEDs to flash and then try clicking 'Save' on the Config screen again. This should retry the connection. But in your case I can see from the log that it didn't even try opening a port, so it couldn't find the connection at all.

Which Windows version are you using? My driver searches the registry for the correct port but maybe it isn't working on an older Windows.

Can you look into the Device Manager screen? As always with Windows (10) there are different ways to do this, none particularly convenient!

  1. Windows+R keys, then type in C:\Windows\System32\devmgmt.msc
  2. In Windows Explorer, browse to C:\Windows\System32 and double click on devmgmt.msc
  3. In Windows Explorer right-click on 'This PC' and select Manage. Then select Device Manager on the screen that appears.

Open the Ports section. Do you see a line with 'Silicon Labs' and 'USB to UART' in the list (like the screen shown in my PDF), and if so which COM port is it connected to? If not, unplug the board again and plug it back in. One of the ports should have disappeared and then reappeared again.

Once you know the COM port number (e.g. COM8) you can try setting that in the Config screen of my driver instead of 'Auto'. That might help.

Please let me know what you find!

Thanks, Graham

 

 

 

 

I think I've found the problem! There was an error in the processing of 'Auto' if you only had one COM port.

I've uploaded a fixed version to my web page.

Thanks, Graham

 

Thank´s a lot for your help! I selected the port manually and now everything works perfectly!

 

Julian

Quote from Graham on November 21, 2020, 4:55 am

I think I've found the problem! There was an error in the processing of 'Auto' if you only had one COM port.

I've uploaded a fixed version to my web page.

Thanks, Graham

 

Hi Graham

Thank you for the help!

Pietro

What I like very much is the LED´s guiding me during the take back.

I whish, integrating such a function in Certabodroid would be possible......

 

Julian

Hi Julian,

Thank you for your feedback. It's really useful when somebody says they have a problem and it's really nice when somebody says they like something!

Graham